diff options
Diffstat (limited to 'debian/rules')
-rwxr-xr-x | debian/rules | 57 |
1 files changed, 57 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules new file mode 100755 index 0000000..389c597 --- /dev/null +++ b/debian/rules | |||
@@ -0,0 +1,57 @@ | |||
1 | #!/usr/bin/make -f | ||
2 | # GNU copyright 1997 to 1999 by Joey Hess. | ||
3 | |||
4 | # Uncomment this to turn on verbose mode. | ||
5 | #export DH_VERBOSE=1 | ||
6 | |||
7 | # This is the debhelper compatability version to use. | ||
8 | export DH_COMPAT=3 | ||
9 | |||
10 | configure: configure-stamp | ||
11 | configure-stamp: | ||
12 | dh_testdir | ||
13 | touch configure-stamp | ||
14 | |||
15 | build: configure-stamp build-stamp | ||
16 | build-stamp: | ||
17 | dh_testdir | ||
18 | $(MAKE) | ||
19 | touch build-stamp | ||
20 | |||
21 | clean: | ||
22 | dh_testdir | ||
23 | dh_testroot | ||
24 | rm -f build-stamp configure-stamp | ||
25 | -$(MAKE) clean | ||
26 | dh_clean | ||
27 | |||
28 | install: build | ||
29 | dh_testdir | ||
30 | dh_testroot | ||
31 | dh_clean -k | ||
32 | dh_installdirs | ||
33 | $(MAKE) install DESTDIR=$(CURDIR)/debian/vchat-client PREFIX=/usr | ||
34 | |||
35 | |||
36 | # Build architecture-independent files here. | ||
37 | binary-indep: build install | ||
38 | # We have nothing to do by default. | ||
39 | |||
40 | # Build architecture-dependent files here. | ||
41 | binary-arch: build install | ||
42 | dh_testdir | ||
43 | dh_testroot | ||
44 | dh_installdocs | ||
45 | dh_installchangelogs | ||
46 | dh_link | ||
47 | dh_strip | ||
48 | dh_compress | ||
49 | dh_fixperms | ||
50 | dh_installdeb | ||
51 | dh_shlibdeps | ||
52 | dh_gencontrol | ||
53 | dh_md5sums | ||
54 | dh_builddeb | ||
55 | |||
56 | binary: binary-indep binary-arch | ||
57 | .PHONY: build clean binary-indep binary-arch binary install configure | ||