diff options
author | erdgeist <> | 2003-02-12 17:48:37 +0000 |
---|---|---|
committer | erdgeist <> | 2003-02-12 17:48:37 +0000 |
commit | dea6bf757aa9a875eab35b2b650412e7605f1308 (patch) | |
tree | 14ed8374c3a3862529313088375693a7de70d3a7 /debian |
CVS moved to erdgeist.org
Diffstat (limited to 'debian')
-rwxr-xr-x | debian/changelog | 16 | ||||
-rwxr-xr-x | debian/control | 12 | ||||
-rwxr-xr-x | debian/copyright | 12 | ||||
-rwxr-xr-x | debian/dirs | 1 | ||||
-rwxr-xr-x | debian/docs | 2 | ||||
-rwxr-xr-x | debian/rules | 57 |
6 files changed, 100 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog new file mode 100755 index 0000000..17e8bf7 --- /dev/null +++ b/debian/changelog | |||
@@ -0,0 +1,16 @@ | |||
1 | vchat-client (0.15-2) unstable; urgency=low | ||
2 | |||
3 | * changed debian/rules using "make install" | ||
4 | * added manpage | ||
5 | |||
6 | -- Hans Freitag <macrotron@president.eu.org> Wed, 30 Nov 2001 14:47:54 +0200 | ||
7 | |||
8 | vchat-client (0.15-1) unstable; urgency=low | ||
9 | |||
10 | * Current Version | ||
11 | |||
12 | -- Andreas Kotes <count@flatline.de> Wed, 28 Nov 2001 23:28:54 +0200 | ||
13 | |||
14 | Local variables: | ||
15 | mode: debian-changelog | ||
16 | End: | ||
diff --git a/debian/control b/debian/control new file mode 100755 index 0000000..d106fd5 --- /dev/null +++ b/debian/control | |||
@@ -0,0 +1,12 @@ | |||
1 | Source: vchat-client | ||
2 | Section: unknown | ||
3 | Priority: optional | ||
4 | Maintainer: Andreas Kotes <count@flatline.de> | ||
5 | Build-Depends: debhelper (>> 3.0.0), libreadline4-dev, libncurses-dev, libssl-dev, docbook-to-man | ||
6 | Standards-Version: 3.5.2 | ||
7 | |||
8 | Package: vchat-client | ||
9 | Architecture: any | ||
10 | Depends: ${shlibs:Depends} | ||
11 | Description: client for the vchat | ||
12 | This client uses ssl | ||
diff --git a/debian/copyright b/debian/copyright new file mode 100755 index 0000000..e066d1d --- /dev/null +++ b/debian/copyright | |||
@@ -0,0 +1,12 @@ | |||
1 | This package was debianized by Sebastian Klemke <cBP@gmx.de> on | ||
2 | Thu, 23 Aug 2001 18:41:57 +0200. | ||
3 | |||
4 | It was downloaded from berlin.ccc.de | ||
5 | |||
6 | Upstream Author(s): Andreas Kotes <count@flatline.de> | ||
7 | |||
8 | Copyright: | ||
9 | |||
10 | The client is copyright (c) 2001 Andreas Kotes, it is distributed under the | ||
11 | terms of the GNU General Public License, the GPL should be in | ||
12 | /usr/share/common-licenses/GPL on a debian system. | ||
diff --git a/debian/dirs b/debian/dirs new file mode 100755 index 0000000..e772481 --- /dev/null +++ b/debian/dirs | |||
@@ -0,0 +1 @@ | |||
usr/bin | |||
diff --git a/debian/docs b/debian/docs new file mode 100755 index 0000000..724e084 --- /dev/null +++ b/debian/docs | |||
@@ -0,0 +1,2 @@ | |||
1 | README | ||
2 | TODO | ||
diff --git a/debian/rules b/debian/rules new file mode 100755 index 0000000..389c597 --- /dev/null +++ b/debian/rules | |||
@@ -0,0 +1,57 @@ | |||
1 | #!/usr/bin/make -f | ||
2 | # GNU copyright 1997 to 1999 by Joey Hess. | ||
3 | |||
4 | # Uncomment this to turn on verbose mode. | ||
5 | #export DH_VERBOSE=1 | ||
6 | |||
7 | # This is the debhelper compatability version to use. | ||
8 | export DH_COMPAT=3 | ||
9 | |||
10 | configure: configure-stamp | ||
11 | configure-stamp: | ||
12 | dh_testdir | ||
13 | touch configure-stamp | ||
14 | |||
15 | build: configure-stamp build-stamp | ||
16 | build-stamp: | ||
17 | dh_testdir | ||
18 | $(MAKE) | ||
19 | touch build-stamp | ||
20 | |||
21 | clean: | ||
22 | dh_testdir | ||
23 | dh_testroot | ||
24 | rm -f build-stamp configure-stamp | ||
25 | -$(MAKE) clean | ||
26 | dh_clean | ||
27 | |||
28 | install: build | ||
29 | dh_testdir | ||
30 | dh_testroot | ||
31 | dh_clean -k | ||
32 | dh_installdirs | ||
33 | $(MAKE) install DESTDIR=$(CURDIR)/debian/vchat-client PREFIX=/usr | ||
34 | |||
35 | |||
36 | # Build architecture-independent files here. | ||
37 | binary-indep: build install | ||
38 | # We have nothing to do by default. | ||
39 | |||
40 | # Build architecture-dependent files here. | ||
41 | binary-arch: build install | ||
42 | dh_testdir | ||
43 | dh_testroot | ||
44 | dh_installdocs | ||
45 | dh_installchangelogs | ||
46 | dh_link | ||
47 | dh_strip | ||
48 | dh_compress | ||
49 | dh_fixperms | ||
50 | dh_installdeb | ||
51 | dh_shlibdeps | ||
52 | dh_gencontrol | ||
53 | dh_md5sums | ||
54 | dh_builddeb | ||
55 | |||
56 | binary: binary-indep binary-arch | ||
57 | .PHONY: build clean binary-indep binary-arch binary install configure | ||